Java 8.6 Workaround in Internet Explorer 11

Unfortunately, the latest version of Java has been causing loading issues in Internet Explorer 11. We recommend using Firefox at this time for the smoothest experience playing Pogo’s Java games.

If you have not yet installed 8.6 should avoid upgrading to Java 8u6 at this time. If you have already installed 8u6 and would like to continue using Internet Explorer 11, there is a workaround. You must downgrade to an older version of Java, specifically version 8u51, available from Oracle’s website.

Note: If you are on Windows, you should get the x86 (32-bit) version of Java 8u51. Be aware that to download Java 8u51 from Oracle will ask you to create an Oracle account.

Oracle's Past Java version download page.

Thank you for your understanding.

-The Pogo Team

 

  • Share this post:
  • Facebook
  • Twitter

Comments are closed